Hoppa till huvudinnehåll

Hur rankar jag värden exklusive delsumma i Excel?

Det finns ett sortiment som innehåller butiker, regioner, försäljning och delsumman av försäljningen i varje region. Nu är jobbet att rangordna all försäljning exklusive delsumma enligt nedanstående skärmdump, hur kan du snabbt hantera det i Excel?
doc rank exkludera delsumma 1

Rank exklusive delsumma


pil blå höger bubbla Rank exklusive delsumma

För att rangordna värden exklusive delsumma behöver du en hjälpkolumn.

1. Välj en tom cell bredvid värdet du vill rangordna, skriv 1 i den och dra sedan handtaget för automatisk fyllning nedåt för att fylla serienummer tills delsumman uppnås. se skärmdump:
doc rank exkludera delsumma 2

2. Gå sedan till nästa värde du vill rangordna för att fortsätta fylla serienumren, och upprepa detta steg för att fylla alla värden du vill rangordna med serienummer. Se skärmdump:
doc rank exkludera delsumma 3

3. Sedan kan du rangordna värdena exklusive delsummor. Välj en tom cell, E2, skriv den här formeln, =OM(N(D2),RANK(C2,$C$2:$C$16,1),"") (C2 är cellen som du vill rangordna, D2 är serienumret, C2:C16 är listan över värden du vill rangordna), och dra sedan fyllningshandtaget ner till cellerna som behöver tillämpa denna formel. Se skärmdump:
doc rank exkludera delsumma 4

Notera:

Om du vill rangordna värden i fallande ordning kan du använda den här formeln=OM(N(E2),RANK(E2,$E$2:$E$16),""), E2:E16 är intervallet som innehåller formeln =OM(N(D2),RANK(C2,$C$2:$C$16,1),"").
doc rank exkludera delsumma 5

Bästa kontorsproduktivitetsverktyg

Populära funktioner: Hitta, markera eller identifiera dubbletter   |  Ta bort tomma rader   |  Kombinera kolumner eller celler utan att förlora data   |   Rund utan formel ...
Superuppslag: Flera kriterier VLookup    VLookup med flera värden  |   VSök över flera ark   |   Fuzzy Lookup ....
Avancerad rullgardinslista: Skapa snabbt en rullgardinslista   |  Beroende rullgardinslista   |  Flervals-rullgardinslista ....
Kolumnhanterare: Lägg till ett specifikt antal kolumner  |  Flytta kolumner  |  Växla synlighetsstatus för dolda kolumner  |  Jämför intervall och kolumner ...
Utvalda funktioner: Rutnätsfokus   |  Designvy   |   Stor formelbar    Arbetsbok & Bladhanterare   |  Resursbibliotek (Automatisk text)   |  Datumväljare   |  Kombinera arbetsblad   |  Kryptera/Dekryptera celler    Skicka e-postmeddelanden efter lista   |  Superfilter   |   Specialfilter (filtrera fet/kursiv/genomstruken...) ...
Topp 15 verktygssatser12 text verktyg (lägga till text, Ta bort tecken, ...)   |   50 + Diagram Typer (Gantt Chart, ...)   |   40+ Praktiskt Formler (Beräkna ålder baserat på födelsedag, ...)   |   19 Införande verktyg (Infoga QR-kod, Infoga bild från sökväg, ...)   |   12 Konvertering verktyg (Siffror till ord, Valutaväxling, ...)   |   7 Slå ihop och dela verktyg (Avancerade kombinera rader, Dela celler, ...)   |   ... och mer

Uppgradera dina Excel-färdigheter med Kutools för Excel och upplev effektivitet som aldrig förr. Kutools för Excel erbjuder över 300 avancerade funktioner för att öka produktiviteten och spara tid.  Klicka här för att få den funktion du behöver mest...

kte-flik 201905


Fliken Office ger ett flikgränssnitt till Office och gör ditt arbete mycket enklare

  • Aktivera flikredigering och läsning i Word, Excel, PowerPoint, Publisher, Access, Visio och Project.
  • Öppna och skapa flera dokument i nya flikar i samma fönster, snarare än i nya fönster.
  • Ökar din produktivitet med 50 % och minskar hundratals musklick för dig varje dag!
Comments (1)
No ratings yet. Be the first to rate!
This comment was minimized by the moderator on the site
This is incorrect as if your subtotal is less than one of the values you are looking to rank it will push that value up in rank, the only reason this example works is because all subtotals are higher than the values you want ranked so they appear in rank from 1-12.
There are no comments posted here yet
Please leave your comments in English
Posting as Guest
×
Rate this post:
0   Characters
Suggested Locations