Note: The other languages of the website are Google-translated. Back to English

Hur hittar jag värde i en cell med kommaseparerad lista i Excel?

Om du antar att du har en kolumn innehåller kommaseparerade värden som försäljning, 123, AAA, och nu vill du hitta om värdet 123 i den kommaseparerade cellen, hur kan du göra det? Denna artikel kommer att introducera metod för att lösa problemet.

Hitta värde i en cell med kommaseparerad lista med formel


Hitta värde i en cell med kommaseparerad lista med formel

Följande formel kan hjälpa dig att hitta värde i en cell med kommaseparerad lista i Excel. Gör så här.

1. Välj en tom cell, ange formel =IF(ISNUMBER(SEARCH(123,A2)),"yes","no") in i formelfältet och tryck sedan på Enter. Se skärmdump:

Anmärkningar: i formeln är A2 cellen innehåller de kommaseparerade värdena du hittar.

2. Fortsätt att välja resultatcellen och dra ner Fill Handle för att få alla resultat. Om värdet "123" finns i de kommaseparerade cellerna får du resultatet som "Ja"; annars får du resultatet som ”Nej”. Se skärmdump:


Relaterade artiklar:


De bästa Office-produktivitetsverktygen

Kutools för Excel löser de flesta av dina problem och ökar din produktivitet med 80%

  • återanvändning: Sätt snabbt i komplexa formler, diagram och allt som du har använt tidigare; Kryptera celler med lösenord; Skapa e-postlista och skicka e-post ...
  • Super Formula Bar (enkelt redigera flera rader med text och formel); Läslayout (enkelt läsa och redigera ett stort antal celler); Klistra in i filtrerat intervall...
  • Sammanfoga celler / rader / kolumner utan att förlora data; Delat cellinnehåll; Kombinera duplicerade rader / kolumner... Förhindra duplicerade celler; Jämför intervall...
  • Välj Duplicera eller Unikt Rader; Välj tomma rader (alla celler är tomma); Super Find och Fuzzy Find i många arbetsböcker; Slumpmässigt val ...
  • Exakt kopia Flera celler utan att ändra formelreferens; Skapa referenser automatiskt till flera ark; Sätt in kulor, Kryssrutor och mer ...
  • Extrahera text, Lägg till text, ta bort efter position, Ta bort mellanslag; Skapa och skriva ut personsökningstalsatser; Konvertera mellan celler innehåll och kommentarer...
  • Superfilter (spara och tillämpa filterscheman på andra ark); Avancerad sortering efter månad / vecka / dag, frekvens och mer; Specialfilter av fet, kursiv ...
  • Kombinera arbetsböcker och arbetsblad; Sammanfoga tabeller baserat på nyckelkolumner; Dela data i flera ark; Batchkonvertera xls, xlsx och PDF...
  • Mer än 300 kraftfulla funktioner. Stöder Office / Excel 2007-2021 och 365. Stöder alla språk. Enkel implementering i ditt företag eller organisation. Fullständiga funktioner 30 dagars gratis provperiod. 60 dagars pengarna tillbaka-garanti.
kte-flik 201905

Fliken Office ger ett flikgränssnitt till Office och gör ditt arbete mycket enklare

  • Aktivera flikredigering och läsning i Word, Excel, PowerPoint, Publisher, Access, Visio och Project.
  • Öppna och skapa flera dokument i nya flikar i samma fönster, snarare än i nya fönster.
  • Ökar din produktivitet med 50 % och minskar hundratals musklick för dig varje dag!
officetab botten
Sortera kommentarer efter
Kommentarer (16)
Inga betyg än. Bli först med att betygsätta!
Denna kommentar minimerades av moderatoren på webbplatsen
God morgon till alla. Jag har en excel-fråga om hur man räknar kommaseparerade specifika värden i en enda cell i excel. Jag vill räkna antalet 15:or i en enda cell som innehåller 15,215,15,155,45,1515,15 Jag behöver resultat 3. Finns det någon formel i excel.
Denna kommentar minimerades av moderatoren på webbplatsen
Ja, det finns en funktion i Excel som kan göra detta åt dig. Men som förklarat i problemet ovan för att få bättre noggrannhet för dina data lägg till ett kommatecken till vänster och höger om din lista och inkludera det i din sökning. Se exempel nedan:
, 15,215,15,155,45,1515,15,
=ANTALOM(A1; ";15,"")
Förklaringen av denna formel är som följer: =ANTALOM(cellnummer eller intervall, värde du letar efter/räknas)
Säg till om du behöver ett bättre exempel.
Denna kommentar minimerades av moderatoren på webbplatsen
Hallå!
Detta är en riktigt cool formel, men den har ... brister? ... att jag inte kan komma på hur jag ska komma runt det. "Fel" är inte det korrekta ordet, men jag kan inte komma på (det är 8:30 på måndagen) på rätt ord.
När du letar efter någon del av ett nummer får du "ja". Så alla följande returnerar "ja":
=OM(ÄRNUMMER(SÖK(12,A2)),"ja","nej")
=OM(ÄRNUMMER(SÖK(23,A2)),"ja","nej")
=OM(ÄRNUMMER(SÖK(3,A2)),"ja","nej")

Jag försökte slå in siffrorna inom citattecken utan resultat. Formeln fungerar perfekt för exemplets användningsfall, där alla siffror är av samma längd. Men om du letar efter ett kortare nummer som råkar dyka upp i strängen får du en falsk positiv.
Finns det ett alternativ till "SÖK" som är mer bokstavligt (igen, är det ordet? haha)? 
Tack! 
Denna kommentar minimerades av moderatoren på webbplatsen
Hej Scott S., menar du sök efter den exakta strängen?
Denna kommentar minimerades av moderatoren på webbplatsen
Hej Crystal.
Ja, jag antar att det är så man formulerar det. 
Den aktuella lösningen kommer att returnera "Ja" för valfri del av nummersträngen. Så siffrorna 1, 2, 3, 12, 23 och 123 kommer alla att returnera "Ja". 
Jag har försökt komma på en lösning som kommer att söka efter en sträng med siffror och returnera "Ja" för en exakt matchning. 
Denna kommentar minimerades av moderatoren på webbplatsen
Hej Scott S, Tack för din feedback. Jag har inte hittat lösningen än och återkommer om jag hittat den.
Denna kommentar minimerades av moderatoren på webbplatsen
Jag har hittat en lösning på detta. Om du lägger till ett kommatecken till vänster och höger om din lista och inkluderar dem (som en smörgås) i din sökning kommer det att tillåta dig att hitta en exakt matchning. Exempel nedan:
, 123,231,321,122,321,1,2,3,23,
SÖK(",23,"")
På så sätt tvingar den sökningen att matcha från ett kommatecken till det andra snarare än bara en del av posten från listan. Hoppas det är detta du letade efter?
Denna kommentar minimerades av moderatoren på webbplatsen
Jag har hittat en lösning. Om du lägger till ett kommatecken till vänster och höger om din lista kommer det att krävas sökfunktionen för att hitta en exakt matchning från komma till komma. Se exempel nedan:
=OM(ÄRNUMMER(SÖK(",12,",A2)),"ja","nej")

, 312,123,10,112,126,
Detta kommer att returnera false eftersom det inte finns någon variabel från komma till komma (,12,) som matchar sökningen. 
Om du behöver ytterligare förtydliganden, låt mig veta och skicka ett bättre exempel. Jag hade samma problem när jag automatiserade en rapport för min chef och fick en uppenbarelse. :)
Denna kommentar minimerades av moderatoren på webbplatsen
Hej, jag kan fortfarande inte komma på det här. Jag har fortfarande samma problem. istället för att använda nummer i formeln använder jag en cellreferens. till exempel om jag söker efter "1"(Q$1) i (123, 25,29,200)($J2) ger det mig fortfarande JA. Formeln är =OM(ISNUMBER(SÖK(Q$1,$J2)),"ja","nej")

PS: Jag har en stor datamängd som jag inte kan sätta kommatecken före och efter i varje cell. Kommer att uppskatta en lösning
Denna kommentar minimerades av moderatoren på webbplatsen
Hej snälla hjälp

Jag har tabell i Excel med två kolumner A & B, under A finns det värde T.ex. A2 Cell har 1,2,2,1,2,1,2 etc (har bara två siffror 1 och 2 men måste känna igen den har bara 1 & 2 i hela cellen och inget annat tal) och A3 har 1,1,1 och A4 har 0, A5 har 2,2,2,2 och A6 har 20. Jag vill att B2 ska returnera värdet för A2 som Asien , B3 Afrika, B4 som Ingen, B5 som Amerika och B6 som Europa. Jag trodde att jag kunde använda if-formeln men den kan inte känna igen kommaseparerade tal och returvärde). Snälla hjälp
Denna kommentar minimerades av moderatoren på webbplatsen
Vad sägs om det här, jag måste få värdena i A och likställa dem med siffrorna i C och returnera värdena i B separerade som kommatecken respektive till C.

Tack
Denna kommentar minimerades av moderatoren på webbplatsen
Hej duncan,
Om du använder Excel för 365 kan följande formel hjälpa dig att lösa problemet.
=TEXTJOIN(",",TRUE,XLOOKUP(TRANSPOSE(VALUE(TEXTSPLIT(D1,","))),A1:A3,B1:B3,"",0,1))
Denna formel fungerar bara i Excel för 365. För andra Excel-versioner än Excel för 365 har jag inte hittat en formel som hanterar det..
https://www.extendoffice.com/images/stories/comments/comment-picture-zxm/find-value.png
Denna kommentar minimerades av moderatoren på webbplatsen
Hej alla, jag har en cell som har flera länder separerade med kommatecken
Exempel: A2-cellvärdet är (Indien, Japan, Malaysia, Stor-Kina)
Kolumn G har landsnamnen
Nu måste jag leta efter en formel som jämför värde från kolumn G med värde i A2-cell.
Om värdet matchar, returnera true annars returnera False
Denna kommentar minimerades av moderatoren på webbplatsen
Hej Mohini Verma,
Formeln kan ändras enligt följande:
=OM(ÄRNUMMER(SÖK(G2,A2)),"TRUE","FALSE")
Denna kommentar minimerades av moderatoren på webbplatsen
Hej, jag kan fortfarande inte komma på det här. Jag har fortfarande samma problem. istället för att använda nummer i formeln använder jag en cellreferens. till exempel om jag söker efter "1"(Q$1) i (123, 25,29,200)($J2) ger det mig fortfarande JA. Formeln är =OM(ISNUMBER(SÖK(Q$1,$J2)),"ja","nej")

PS: Jag har en stor datamängd som jag inte kan sätta kommatecken före och efter i varje cell. Kommer att uppskatta en lösning
Denna kommentar minimerades av moderatoren på webbplatsen
Hej Hassam

Använd bara följande formel utan OM-funktionen. Om siffran stämmer exakt, får du resultatet "SANN", annars får du resultatet"FALSK".
=ISNUMBER(FIND(",1,",","&$J2&","))
https://www.extendoffice.com/images/stories/comments/comment-picture-zxm/match.png
Det finns inga kommentarer här ännu
Lämna dina kommentarer
Postar som gäst
×
Betygsätt detta inlägg:
0   Tecken
Föreslagna platser

Följ oss

Copyright © 2009 - www.extendoffice.com. | Alla rättigheter förbehållna. Drivs av ExtendOffice. | | Sitemap
Microsoft och Office-logotypen är varumärken eller registrerade varumärken som tillhör Microsoft Corporation i USA och / eller andra länder.
Skyddad av Sectigo SSL