Hoppa till huvudinnehåll

Räkna antalet celler inte mellan två givna nummer i Excel

Att räkna antalet celler mellan två nummer är en vanlig uppgift för oss i Excel, men i vissa fall kanske du vill räkna cellerna inte mellan två givna nummer. Till exempel har jag en produktlista med försäljningen från måndag till söndag, nu måste jag få antalet celler som inte ligger mellan de specifika låga och höga siffrorna som visas nedan. Denna artikel kommer att introducera några formler för att hantera denna uppgift i Excel.


Räkna antalet celler som inte ligger mellan två givna tal med COUNTIF-funktionen

COUNTIF-funktionen i Excel kan hjälpa dig att lösa det här jobbet, den generiska syntaxen är:

=COUNTIF(range,"<"&low)+COUNTIF(range,">"&high)
  • range: Dataintervallet som innehåller de värden du vill räkna;
  • low: Cellen som innehåller den nedre gränsen för intervallet;
  • high: Cellen som innehåller den övre gränsen för intervallet;
  • &: Denna separator används för att sammanfoga cellvärdet med villkoren.

1. Ange eller kopiera följande formel till en tom cell:

=COUNTIF(B2:H2,"<"&J2)+COUNTIF(B2:H2,">"&K2)

2. Dra fyllningshandtaget ner till de celler som du vill använda denna formel, sedan har alla antalet celler som inte ligger mellan de två givna talen beräknats, se skärmdump:


Förklaring av formeln:
  • ANTALOM(B2:H2,"<"&J2): Denna COUNTIF-funktion kommer att få antalet celler under värdet i J2, den returnerar resultatet:3.
  • COUNTIF(B2:H2,">"&K2): Denna COUNTIF-funktion kommer att få antalet celler över värdet i K2, den returnerar resultatet:1.
  • COUNTIF(B2:H2,"<"&J2)+COUNTIF(B2:H2,">"&K2)=3+1: Lägg till dessa två resultat för att få den nödvändiga logiken: mindre än J2 eller större än K2.

Räkna antalet celler som inte ligger mellan två givna tal med SUMPRODUKT-funktionen

Här finns också en SUMPRODUCT-funktion som kan hjälpa dig att räkna antalet celler som inte ligger mellan två tal, den generiska syntaxen är:

=SUMPRODUCT((range<low)+(range>high))
  • range: Dataintervallet som innehåller de värden du vill räkna;
  • low: Cellen som innehåller den nedre gränsen för intervallet;
  • high: Cellen som innehåller den övre gränsen för intervallet;

1. Ange eller kopiera nedanstående formel till en tom cell:

=SUMPRODUCT((B2:H2<J2)+(B2:H2>K2))

2. Och dra sedan fyllningshandtaget ner till cellerna som du vill använda den här formeln så får du resultatet på en gång, se skärmdump:


Förklaring av formeln:
  • I den här formeln behöver du inte använda & separator för att sammanfoga cellreferenserna, och tilläggstecknet (+) här skapar en ELLER-logik.
  • Den här formeln kommer att utvärdera varje array och returnera TRUE eller FALSE för varje värde, eftersom detta: =SUMPRODUKT({FALSE,TRUE,FALSE,FALSE,TRUE,TRUE,FALSE}+{TRUE,FALSE,FALSE,FALSE,FALSE,FALSE, FALSK})
  • Och den matematiska operationen kommer att omvandla SANT och FALSKT värden till 1:or och 0:or så här: =SUMMAPRODUKT({0,1,0,0,1,1,0}+{1,0,0,0,0,0,0, XNUMX})
  • Lägg till sist till de två arrayerna för att få resultatet: =SUMPRODUKT({1, 1, 0, 0, 1,1.0})=4.

Relativ funktion som används:

  • COUNTIF:
  • COUNTIF-funktionen är en statistisk funktion i Excel som används för att räkna antalet celler som uppfyller ett kriterium.
  • SUMPRODUCT:
  • SUMPRODUCT-funktionen kan användas för att multiplicera två eller flera kolumner eller matriser tillsammans och sedan få summan av produkter.

Fler artiklar:

  • Räkna antalet celler som inte är lika med många värden i Excel
  • I Excel kan du enkelt få antalet celler som inte är lika med ett specifikt värde med hjälp av COUNTIF -funktionen, men har du någonsin försökt räkna cellerna som inte är lika med många värden? Till exempel vill jag få det totala antalet produkter i kolumn A men utesluta de specifika objekten i C4: C6 enligt nedanstående skärmdump. Denna artikel kommer att introducera några formler för att lösa detta jobb i Excel.
  • Räkna antalet celler är lika med ett av många värden i Excel
  • Om jag antar att jag har en lista över produkter i kolumn A, nu vill jag få det totala antalet specifika produkter Apple, Grape and Lemon som anges i intervall C4: C6 från kolumn A enligt nedanstående skärmdump. Normalt fungerar inte Excel i de här funktionerna i enkla COUNTIF- och COUNTIFS -funktioner. Denna artikel, jag kommer att prata om hur man löser detta jobb snabbt och enkelt med kombinationen av SUMPRODUCT och COUNTIF -funktioner.

De bästa Office-produktivitetsverktygen

Kutools för Excel - Hjälper dig att sticka ut från mängden

Populära funktioner: Hitta, markera eller identifiera dubbletter  |  Ta bort tomma rader  |  Kombinera kolumner eller celler utan att förlora data  |  Rund utan formel ...
Super VLookup: Flera kriterier  |  Multipelt värde  |  Över flera ark  |  Fuzzy Lookup...
Adv. Rullgardinslista: Enkel rullgardinslista  |  Beroende rullgardinslista  |  Flervals-rullgardinslista...
Kolumnhanterare: Lägg till ett specifikt antal kolumner  |  Flytta kolumner  |  Växla synlighetsstatus för dolda kolumner  Jämför kolumner med Välj Samma och olika celler ...
Utvalda funktioner: Rutnätsfokus  |  Designvy  |  Stor formelbar  |  Arbetsbok & Bladhanterare | Resursbibliotek (Automatisk text)  |  Datumväljare  |  Kombinera arbetsblad  |  Kryptera/Dekryptera celler  |  Skicka e-postmeddelanden efter lista  |  Superfilter  |  Specialfilter (filtrera fet/kursiv/genomstruken...) ...
Topp 15 verktygssatser12 text verktyg (lägga till text, Ta bort tecken ...)  |  50 + Diagram Typer (Gantt Chart ...)  |  40+ Praktiskt Formler (Beräkna ålder baserat på födelsedag ...)  |  19 Införande verktyg (Infoga QR-kod, Infoga bild från sökväg ...)  |  12 Konvertering verktyg (Siffror till ord, Valutaväxling ...)  |  7 Slå ihop och dela verktyg (Avancerade kombinera rader, Dela upp Excel-celler ...)  |  ... och mer

Kutools för Excel har över 300 funktioner, Se till att det du behöver bara är ett klick bort...


Fliken Office - Aktivera läsning och redigering av flikar i Microsoft Office (inkluderar Excel)

  • En sekund att växla mellan dussintals öppna dokument!
  • Minska hundratals musklick åt dig varje dag, säg adjö till mushanden.
  • Ökar din produktivitet med 50 % när du visar och redigerar flera dokument.
  • Ger effektiva flikar till Office (inklusive Excel), precis som Chrome, Edge och Firefox.
Comments (0)
No ratings yet. Be the first to rate!
There are no comments posted here yet
Please leave your comments in English
Posting as Guest
×
Rate this post:
0   Characters
Suggested Locations