Hoppa till huvudinnehåll

 Hur genomsnittliga topp- eller bottenvärden i Excel?

I Excel kan vi snabbt och enkelt beräkna medelvärdet av ett cellintervall genom att använda funktionen MEDEL. Ibland behöver vi medelvärde av de största eller minsta n värdena i en lista med celler i slumpmässig ordning, hur kan vi få medelvärdet av de översta eller nedersta n värdena i Excel?

Genomsnittliga topp- eller lägsta 3-värden med formler

Genomsnitt exklusive de övre eller nedre 3 värdena med formler

Genomsnitt exklusive översta och nedersta 3 värden med formel


pil blå höger bubbla Genomsnittliga topp- eller lägsta 3-värden med formler

I det här exemplet kommer jag att beräkna genomsnittet av de största eller minsta 3 siffrorna, följande formler kan göra dig en tjänst.

För att få medelvärdet av de tre största värdena, ange denna formel:

=MEDEL(STOR(A2:A20,RAD(1:3))), (A2: A10 är dataintervallet som du vill beräkna ett genomsnitt, 1:3 indikerar antalet av de största värdena du behöver, om du vill ta ett genomsnitt av de största 10 värdena behöver du bara ändra det till 1:10. ), och tryck sedan på Ctrl + Skift + Enter för att få rätt resultat. Se skärmdump:

Doc-genomsnittet-Top-3-1

För att få ett medelvärde för de minsta 3 värdena kan du använda den här formeln: =MEDEL(LITEN(A2:A20,RAD(1:3))) (även, om du vill beräkna medelvärdet för de minsta 10 värdena, ändra 1:3 till 1:10), och kom ihåg att trycka på Ctrl + Skift + Enter för att returnera rätt resultat.


pil blå höger bubbla Genomsnitt exklusive de övre eller nedre 3 värdena med formler

Ibland kan du behöva beräkna medelvärdet av andra siffror exklusive de 3 översta eller nedersta värdena, detta kan också lösas med formler i Excel.

För att beräkna medeltalet som exkluderar de tre översta värdena, skriv in den här formeln:

=AVERAGE(IF(A2:A20<LARGE(A2:A20,3),A2:A20))( A2: A10 är dataintervallet som du vill beräkna genomsnittet av, antalet 3 indikerar numret på det största värdet, om du vill ta ett medelvärde och ignorera de största 10 värdena behöver du bara ändra 3 till 10), och sedan trycka på Ctrl + Skift + Enter för att få det resultat du vill ha.

Doc-genomsnittet-Top-3-2

För att få ett genomsnitt av siffrorna exklusive de 3 nedersta värdena, skriv in den här formeln: =AVERAGE(IF(A2:A20>SMALL(A2:A20,3),A2:A20)) (numret 3 indikerar numret på det minsta värdet, om du vill ta ett medelvärde och ignorera de minsta 10 värdena behöver du bara ändra 3 till 10), och bör trycka på Ctrl + Skift + Enter tangenter efter att ha angett denna formel.


pil blå höger bubbla Genomsnitt exklusive översta och nedersta 3 värden med formel

Om du under tiden behöver ta ett medelvärde för de siffror som utesluter både de tre översta och nedersta värdena, kan jag också prata om en formel för dig.

Ange denna formel: =AVERAGE(IF(A2:A20>SMALL(A2:A20,3),IF(A2:A20<LARGE(A2:A20,3),A2:A20))), (A2: A10 är dataintervallet som du vill beräkna genomsnittet av, antalet 3 indikerar numret på det största och minsta värdet, om du vill ta ett medelvärde och ignorera de största och minsta 10 värdena behöver du bara ändra det till 10), tryck sedan på Ctrl + Skift + Enter nycklarna tillsammans för att returnera resultatet.

Doc-genomsnittet-Top-3-3


Relaterade artiklar:

Hur genomsnittar man de senaste 5 värdena i en kolumn när nya siffror kommer in?

Hur genomsnitt varje 5 rader eller kolumner i Excel?

Bästa kontorsproduktivitetsverktyg

Populära funktioner: Hitta, markera eller identifiera dubbletter   |  Ta bort tomma rader   |  Kombinera kolumner eller celler utan att förlora data   |   Rund utan formel ...
Superuppslag: Flera kriterier VLookup    VLookup med flera värden  |   VSök över flera ark   |   Fuzzy Lookup ....
Avancerad rullgardinslista: Skapa snabbt en rullgardinslista   |  Beroende rullgardinslista   |  Flervals-rullgardinslista ....
Kolumnhanterare: Lägg till ett specifikt antal kolumner  |  Flytta kolumner  |  Växla synlighetsstatus för dolda kolumner  |  Jämför intervall och kolumner ...
Utvalda funktioner: Rutnätsfokus   |  Designvy   |   Stor formelbar    Arbetsbok & Bladhanterare   |  Resursbibliotek (Automatisk text)   |  Datumväljare   |  Kombinera arbetsblad   |  Kryptera/Dekryptera celler    Skicka e-postmeddelanden efter lista   |  Superfilter   |   Specialfilter (filtrera fet/kursiv/genomstruken...) ...
Topp 15 verktygssatser12 text verktyg (lägga till text, Ta bort tecken, ...)   |   50 + Diagram Typer (Gantt Chart, ...)   |   40+ Praktiskt Formler (Beräkna ålder baserat på födelsedag, ...)   |   19 Införande verktyg (Infoga QR-kod, Infoga bild från sökväg, ...)   |   12 Konvertering verktyg (Siffror till ord, Valutaväxling, ...)   |   7 Slå ihop och dela verktyg (Avancerade kombinera rader, Dela celler, ...)   |   ... och mer

Uppgradera dina Excel-färdigheter med Kutools för Excel och upplev effektivitet som aldrig förr. Kutools för Excel erbjuder över 300 avancerade funktioner för att öka produktiviteten och spara tid.  Klicka här för att få den funktion du behöver mest...

kte-flik 201905


Fliken Office ger ett flikgränssnitt till Office och gör ditt arbete mycket enklare

  • Aktivera flikredigering och läsning i Word, Excel, PowerPoint, Publisher, Access, Visio och Project.
  • Öppna och skapa flera dokument i nya flikar i samma fönster, snarare än i nya fönster.
  • Ökar din produktivitet med 50 % och minskar hundratals musklick för dig varje dag!
Comments (1)
No ratings yet. Be the first to rate!
This comment was minimized by the moderator on the site
Hi, do you know how to solve this same issue but as a DAX formula? so that I could create a measure in a pivot table. Unfortunately the large function doesn't appear to be available as a DAX.
There are no comments posted here yet
Please leave your comments in English
Posting as Guest
×
Rate this post:
0   Characters
Suggested Locations